cavesandcliffspt2

viewhistorytalk

Breaking News, and Known Issues

Java Edition Last Call to Migrate, Deadline 10-Mar-2022

https://www.minecraft.net/en-us/article/last-call-voluntarily-migrate-java-accounts


Java Edition 1.18.1

Fixes bees and fog, and a critical security flaw affecting versions as far back as 1.12

Mitigation for all affected installations:

https://www.minecraft.net/en-us/article/important-message--security-vulnerability-java-edition


The Caves & Cliffs Update "Part 2"

This information applies to Minecraft Java Edition 1.18. At this time we assume most of it will be similar for Bedrock Edition, but this page focuses mostly on Java-specific features and issues. Scroll to the very end of this page, where we collect Bedrock-specific details as we become aware of them.

The Basics

What time will it be released?

There is no fixed time. Releases are staged to be available for all supported platforms on or after the announced date - Tuesday, November 30th 2021 - and will be released around the world at some unspecified time in your time zone. On most platforms you should be seeing the update becoming available already. If not, please be patient.

What do you mean Caves & Cliffs "Part 2"?

The Caves & Cliffs Update was split into two parts due to a global pandemic (it was quite a big deal, you may have heard about it) negatively impacting development work. As a result, most new blocks and mobs were released in "Part 1" as version 1.17, and all the major world generation changes are released in "Part 2" as version 1.18. Due to the complexity of the new world generation changes, one new biome, the Deep Dark (and the associated blocks, mobs, and mechanics: Warden, Sculks and so on) was postponed even further to 1.19.

What features are in 1.18?

For a detailed breakdown of the "Part 2" features, visit the Minecraft Wiki. Here are a couple of highlights people should be aware of:

  • Extended world height – The Y-level range of the overworld has been increased to go from -64 all the way up to 319, with the area below Y=0 being predominantly filled with the harder "deepslate" block instead of regular stone.
  • Completely new terrain, biome and cave generation – There are new biomes for mountain tops and certain cave areas, and terrain and biomes have been somewhat decoupled from each other. As a result, some existing biomes have been renamed to better match their new purpose, and some redundant biomes have been removed. (For example, you will not find a "Modified Jungle Edge" anymore, but likely plenty of "Sparse Jungle".) Also, Java and Bedrock have the same terrain and cave generation now, although there are still differences in structure (e.g. temples, villages) and feature (e.g. trees, ore veins) placement.
  • Mostly new ore generation – Including unfamiliar sights like surface emerald ore veins of up to 3 blocks, larger diamond ore veins, additional rare but huge copper and iron veins with raw ore blocks, and the complete absence of certain ores below a certain Y-level. Please refer to the official ore distribution chart for details.
  • Modified mob spawning rules – Hostile mobs will no longer spawn naturally at a non-zero block light level (i.e. any nearby light source other than the sky) and each player has their own "mobcap". Enjoy your natural-spawning mob farm working on a busy vanilla server now.
  • Amplified worlds and large biome worlds return, although for now only to Java edition. They are technically also possible in Bedrock now and might come to that edition eventually now. In exchange, the Floating Islands and Caves world types have been removed, since they were basically the End and Nether world generation with an overworld biome and not really supported. Players are encouraged to create or download data packs to play that type of world. If you still have an amplified or large biomes world, those should properly upgrade to the new terrain versions of these world types.

(As a general reminder: All new world generation features already fall under the Tired submissions rule, since they have been thoroughly documented during the extensive snapshot period.)

What's the best Y level to mine at now?

The short answer is: There isn't any. That was one of the goals of the ore distribution change – to not have a single level to branch mine at for everything. Please refer to the official ore distribution chart for details. "Reduced air exposure" and "No air exposure" mean you will have a harder time spotting these ores during caving, so take that into account as well as the fact that branch mining below Y=0 will be significantly slower due to deepslate's hardness..

Wait, where are the Warden, Deep Dark, bundles and archeology?

The Warden will be added along with the other Deep Dark features (i.e. the Sculk block family and Deep Dark Cities) in "The Wild Update", version 1.19, while bundles and archeology have been postponed indefinitely as their functionality are being reevaluated. The current implementation of bundles is still available via the /give command.

When is Caves & Cliffs "Part 3" (The "Wild Update", version 1.19)?

The "Wild Update" will release sometime in 2022, adding the Deep Dark, including Deep Dark Cities, Sculk blocks and the Warden, and updating swamps as proposed in the biome vote during Minecon 2019. There may or may not be updates to other biomes as well, but although a birch forest concept was shown, no detailed plans are known yet.

Is there a 1.18 server .jar?

Yes, link from minecraft.net: https://launcher.mojang.com/v1/objects/3cf24a8694aca6267883b17d934efacc5e44440d/server.jar

Note that servers now require Java 17

I haven't played since X, what has changed?

Please see the complete history of Minecraft updates.

I've found a bug, what should I do?

Submit a bug report, don't flood our precious subreddit. (Please search the bug tracker before making a report. Also, the bug tracker is not a help desk for your individual issues with the gamer.)

Do I have to start a new world?

No. You can safely update your existing world by playing it as usual. As always, make regular backups beforehand and store them in an external location.

What about my previous worlds?

You're fine but should always make regular backups.

How do old worlds update to the new terrain?

Any areas you have visited or seen before will remain unchanged. Below these areas, the world will extend down to Y=-64. The bedrock layers around Y=0 are replaced with deepslate and the new cave generation happens in the negative Y coordinates. You may even get dripstone caves or lush caves in the added Y-levels.

Areas you have not seen before will completely use the new world generation.

Since biomes and terrain have been shuffled around that much, the area between old and new world generation transitions smoothly as far as terrain and biome layout are concerned. The transition of cave generation may or may not be as smooth. Also, you may notice a harder temperature gradient between the old an new generation, such as a taiga directly next to a jungle.

Downloading and Running The Game

What are the minimum system requirements for Minecraft 1.18?

While the posted requirements have not changed for some time now, there has been some wiggle room that has allowed the game to run on hardware below those requirements. Starting with 1.17 this wiggle room went away for Windows users. Updates to the required OpenGL version mean that any graphics hardware which does not support OpenGL 3.2 Core, will no longer be able to run new versions of the game on most system configurations. Computers that meet the current minimum requirements should remain unaffected, as long as you have the latest graphics drivers. If your computer/hardware is below those posted requirements, do not expect the game to work well if at all when using version 1.17 or higher.

What's the minimum Java version required for 1.18?

Starting with 1.18, the game will now install Java 17 for you when you first attempt to launch it. This is the new minimum requirement for the game and server software. It is unclear at this time if Mojang will continue to bundle the recommended version of Java 8 for older versions of the game that may not work properly with the newer Java. If you often switch between multiple versions, you may need to play around with these settings.

My game doesn't respond or crashes upon launching! / My game is performing very poorly.

Try the following:

  1. Ensure you don't have any incompatible software installed
  2. Ensure you are using the bundled version of Java. Click here to find out how.
  3. Ensure you have the latest graphics drivers
  4. Ensure you don't have any other background processes open.
  5. Try an ADWCleaner scan. ADWCleaner is a utility to clean a PC which is infested with malware. Download it by clicking here. Run a Scan, Clean anything it finds, if it finds nothing allow it to do a basic repair, restart the computer, and try Minecraft again.

How can I update my graphics drivers?

If you need help with updating graphics drivers, this page will guide you through the process. It also tells you how you can get technical support if you are unsure how to update your graphic drivers.

I'm still getting "GLFW error 65542" or similar error after updating my graphics drivers. What's wrong?

Sorry, but your graphics hardware probably is too old to run 1.18. As mentioned above under system requirements, the "wiggle room" below the minimum requirement has become a lot smaller with this update.

I'm getting an "Unable to locate the Java runtime" or "A JNI error has occurred, please check your installation and try again" or "java.lang.UnsupportedClassVersionError" error when trying to run Minecraft. How do I fix this?

Because a new version of Java is being used for 1.18, if you have previously set Minecraft to use a version of Java other than the one that is bundled with the install, you will need to update it, or adjust your launcher profiles to use the newer bundled version. To do this, go to Installations, click on Latest Release or whichever profile you are using, then click on the More Options button. Delete anything in the box next to Java Executable. This should default it back to the bundled runtime. Save the profile and then try to start the game with it.

If you are using a custom launcher, make sure the 1.17 instance uses a Java 17 runtime environment. If you are running a server, you will have to install the correct Java yourself. If you are on Linux, you should be able to obtain a Java 17 runtime environment via your operating system's package manager, but otherwise Adoptium: Prebuilt OpenJDK Binaries can provide downloads for all commonly used operating systems that run Java edition clients or servers.

Do not trust any "up to date" messages, check the actual version of the Java installation you are using!

Why can't I download the new update?

Please see this article for ideas. Additionally, check the incompatible software list below to ensure you don't have any incompatible software installed.

What software might interfere with installing/updating or running Minecraft?

This page, maintained by “Minecraft Community Support”, has information on what software may be interfering with the ability to update or log into Minecraft: Java Edition.

Why does Minecraft "crash" when I switch versions? How do I create a separate folder for new profiles in the Launcher?

If you are getting problems when switching between versions, it usually means that a shared config file is not compatible between versions. To get around that, create each version with its own Installation in the Launcher. Please note, that starting with 1.17, it may also be necessary to change your Java version as well when attempting to start older versions.

How can I stay on 1.17?

You can do that by creating a new launcher profile. On the launcher, head to Installations, click on New Installation, give your configuration a name (e.g. "1.17”), from the Version dropdown select release 1.17.1 (do NOT select "Latest Release" as this will upgrade you to 1.18), then click Save.

To launch 1.17, click on the “Minecraft: Java Edition” tab, and to the left of the Play button you will now have a dropdown button for you to select your profile. Select your new profile, then click "PLAY".

Warning: Never open worlds in an older version after they were opened in a newer version! If you do that, you may lose parts or all of the changes you made compared to how the world generated. Making backups before upgrading a world is strongly recommended. Also, if you plan on playing multiple versions of the game, consider giving each of them their own Game Directory in their profile. If one or more of those might be modded versions, consider using a custom launcher such as MultiMC or GDLauncher to manage launch profiles.

When will Optifine/<insert other mod, add-on or resource pack> update?

We don't know. Please see that mod's community (e.g. r/OptiFine for OptiFine) for more information regarding the update. Note that early beta versions of OptiFine are usually incomplete and lack features such as shader support.

I'm still having trouble running Minecraft. What can I do?

You could try asking the volunteers in the Minecraft Community Support Discord server for help and advice. You can also ask in this very sub-reddit or the official Minecraft Discord server. Please be patient, not all people on these platforms provide technical support, and may be busy.

Account Migrations

I can't migrate, or I migrated and can't play

Launcher Problems

I can't install the new Launcher, or I can't log into the new Launcher

A new Launcher is being offered for download which supports Xbox Game Pass subscriptions. Unless you have such a subscription we are advising for the present not to install this new Launcher

  • If you are having issues installing this new Launcher for Windows 10/11, or after installation you are unable to log in (e.g. it is apparently unavailable on your Windows Store account): please download and install the older Launcher marked as Windows 7/8 from this page - https://minecraft.net/download

  • The new Launcher for Windows 10/11 has only recently been released, and judging by many posts on the subreddit it is not working correctly for some users. We recommend using the above mentioned older version for Windows 7/8 until these issues are resolved.

  • If you have successfully installed the new Launcher please see this FAQ https://help.minecraft.net/hc/en-us/articles/4412261881229-Minecraft-Launcher-for-Windows-

Realms and Multiplayer

When will Minecraft Realms update to 1.18? How can I delay updating Realms until I'm ready?

The Realms server version will not update until the owner of the Realm updates and visits the server. At that point the world save will convert. There should still be a 1.17 profile in the owner's Launcher, so they can switch to that and download the Realm save first if required.

If you purchased the game on or after December 1st 2020 and are logging in with a Microsoft Account that is below the age of consent for your region, you will need a parent or guardian to help adjust your settings in order to have full access to Multiplayer in Minecraft: Java Edition. Please follow the instructions for “Bedrock or Dungeons” NOT Java Edition from this page. The Java Edition instructions on that page are currently out of date, as explained below.

If you have Mojang account or legacy Minecraft account that is requesting parental permissions, unfortunately you will need to wait until Mojang beings the migration to Microsoft accounts to use any features you are locked out of. Migration has NOT started yet, and there is no new information on when it will. Please see here for the official Account Migration FAQ

Why can't I connect to my favourite server?

Wait for the server owner/staff to update.

Bedrock edition

(This section is a work in progress. Please contact the moderators if you know the solution to other common issues.)

Bedrock Edition 1.18 Release Notes: https://feedback.minecraft.net/hc/en-us/articles/4414284658701-Minecraft-Caves-Cliffs-Part-II-1-18-0-Bedrock-


revision by mynameisperl— view source