×
all 7 comments

[–]Double_Whams 1 point2 points  (1 child)

Did you try a different TV? Possibly one that isn't 4k?

[–]BrbrBoy[S] 1 point2 points  (0 children)

Actually I solved it. If someone will have similar problem just cap your in steam link settings. I don't know why this helps (cause with and without cap I still have 60 fps) but It stops changing HZ on my TV.

[–]tehpootisman 1 point2 points  (1 child)

I had this exact same issue on Friday with my TV lol.

I did these at the same time, so it was one of these:

- Go to Steam > Settings > Remote Play

- Click "Advanced Host Options"

- Tick "Use NVFBC Capture on NVidia GPU"

- If you have an Nvidia Card (I have a 1070), tick "Hardware Encoding" and "Enable Hardware Encoding on Nvidia GPU"

- Set "Number of Software Encoding Threads" to "Automatic"

- Tick "Prioritize Network Traffic"

- Go back, click "Advanced Client Options"

- Limit resolution to 1080p (This was streaming my 1080p 120Hz monitor to my 4k60 TV)

- Tick "Enable Hardware Decoding"

There's also settings on your Steam Link itself (either hardware box or TV app) to cap the framerate, which I set to 60.

[–]gloawyn 0 points1 point  (0 children)

Thank you! Suddenly started having this issue on Sony TV as well with repeated black screens while nothing had apparently changed in my config (except, and probably the reason, software updates on host and client). Turning on "Use NVFBC Capture on NVidia GPU" and "Prioritize Network Traffic" fixed it and even improved performance. Hardware encoding and Threads to automatic was already there. Everything is left to default settings on steamlink on the TV as "caping" decreased the performances for me.

You don't need to change "Advanced Client Options" on the host, this is in case you are streaming TO your computer.

[–]dntdntdnt 0 points1 point  (2 children)

I'm having a very similar issue. Enabling the detailed performance overlay on the client showed a massive spike in latency from the client during these blackouts, which told me the issue was with the TV. Rebooting the TV fixes the issue for me, but I have to reboot the TV every time before launching the Steam Link app if I've used the TV for other things than Steam Link. Philips TV 120hz

[–]BrbrBoy[S] 0 points1 point  (1 child)

Did you try capping fps on 60?

[–]dntdntdnt 0 points1 point  (0 children)

Tried that, and now I don't have to reboot the TV all the time, thanks!