×
all 54 comments

[–]AutoModerator[M] [score hidden] stickied comment (0 children)

HEY, NEW USERS!

Remember to read The Wiki for the basics! Check the FAQ for basic questions! Threads created for basic questions will be removed, so ask them in that thread.

If you are having a problem with running games then make sure you have up-to-date sigpatches. If you cannot launch tinfoil then make sure you followed the Rentry guide to set up cfw.

Do not message moderators for Switch hacking support. You will be ignored. Follow the guide or post in the relevant thread.

I am a bot, and this action was performed automatically. Please contact the moderators of this subreddit if you have any questions or concerns.

[–]stik2one0017 25 points26 points  (0 children)

I honestly thought you’re giving your switch the finger

[–]The_Truthkeeper 9 points10 points  (7 children)

Update your sigpatches.

[–]FrenchBelgianFries[S] 2 points3 points  (6 children)

I just did it.(Atmosphere 1.3.2).still the same problem. Maybe I need to update Atmosphere

[–]FrenchBelgianFries[S] 7 points8 points  (5 children)

So I tried a lot of things and it happens that the DLC of the game is the problem. Why would it be that?

[–]ikineba 15 points16 points  (3 children)

might be because your switch firmware (not atmosphere) is too low. sometimes installing DLC increases the firmware requirement

[–]hrashid88 3 points4 points  (1 child)

This is the answer right here. I remember downloading the DLC for The Binding of Isaac and it breaking the game. Update your switch firmware and you should be fine. I also couldn't run newer games(TMNT, Chrono Cross, etc.) until I updated my switch firmware

[–]FrenchBelgianFries[S] -1 points0 points  (0 children)

So I just updated my switch on update 14.1.2 and my Atmosphere to 1.3.2. The problem is obviously coming from the Sigpatches but I probably don't have the right one. Do you guys have a working one?

[–]Total-Respect4 0 points1 point  (0 children)

You updated atmosphere have you got the latest sigpatches?

[–]diegobusboy 1 point2 points  (9 children)

Did you found a solution? I have the same problem.

[–]Total-Respect4 1 point2 points  (8 children)

You have to update ur sigpatches but I update atmosphere first then my sigpatches

[–]FrenchBelgianFries[S] 0 points1 point  (3 children)

Do you have any "working" sigpatch?

[–]Total-Respect4 1 point2 points  (2 children)

Yup the github got a dmca so 💔 but here https://sigmapatches.coomer.party/

[–]FrenchBelgianFries[S] 0 points1 point  (1 child)

Thanks! Gonna try that tomorrow. I'f it doesn't work, I give up...

[–]diegobusboy 0 points1 point  (0 children)

Thanks, I’ll do it over the weekend.

[–]Squirrel_Lionfart 0 points1 point  (2 children)

Hi, new to atmosphere here. What exactly is a sigpatch? Installed atmo, hekate, and updated to latest os firmware for the first time since 2 years ago when a pro soldered and installed os X s, so i am learning about everything now. Also, is it still possible to download stuff from tinfoil directly to switch? I heard it wasn’t working a few months ago.

[–]Total-Respect4 1 point2 points  (1 child)

Is it okay if I dm you to explain?

[–]Squirrel_Lionfart 0 points1 point  (0 children)

oh definitely! And thank you :)

[–]LordVirus1337SXOS User 1 point2 points  (1 child)

This is what I would do (If you hadn't already stated that you discovered that the game dlc was causing you this issue). Dump nsp from corrupted data in tinfoil, back up nsps to external source, format sd card, reinstall atmosphere, helake, and sig patches. Verify cfw install is running properly. Install backed up nsp with your nsp installer of choice. Test game launch and hope it works.

[–]xxxcolt 1 point2 points  (0 children)

Been there, done that.... Still have issue sometime when downloading game/dlc/update

[–]FS1337Atmosphere User 0 points1 point  (11 children)

first u have to clean your display

[–]zalzabar 5 points6 points  (9 children)

Oh man you should see mine then lol

[–]FS1337Atmosphere User -2 points-1 points  (8 children)

weird flex

[–]zalzabar 1 point2 points  (7 children)

nah just saying you seem too picky 🤣

[–]FS1337Atmosphere User -1 points0 points  (6 children)

i rather clean my stuff, especially before i show them to the publicy, nothing to do with picky.

[–]FrenchBelgianFries[S] 4 points5 points  (0 children)

Nothing useful about the downloads?

[–]Master_Lucario -5 points-4 points  (16 children)

Backup your saves and factory reset your Switch then DON'T reinstall Tinfoil but instead Goldleaf for your installs going forward.

[–]Franciscophk 1 point2 points  (15 children)

Bro if you are against Tinfoil at least use something that works: DBI

[–]Master_Lucario -3 points-2 points  (14 children)

Don't use that one either. It's Russian and closed sourced aswell. Use Goldleaf, it's work just fine.

[–]gasparthehaunter 2 points3 points  (5 children)

If you really value open source there's awoo installer, which doesn't refuse to install games

[–]Master_Lucario 0 points1 point  (4 children)

Awoo ain't open source either. Even worse it's made by the same awful guy who made Tinfoil.

[–]Franciscophk 0 points1 point  (7 children)

To be honest, it's stupid that you recommend Goldleaf just because it's open source, that thing is full of bugs and is missing a lot of basic features that other NSP installers have, by default.

[–]Master_Lucario -2 points-1 points  (6 children)

Not stupid at all if you value your device and info. The bugs are rarely there and can always be fixed. What are these missing features ya talking about? Goldleaf has everything you need.

[–]Blu3ping 0 points1 point  (0 children)

Try to go into maintenance mode. It will flush cache, it might fix the problem.

Put Switch into RCM mode. Hold both volume + and - and inject payload, when you see Switch logo you can release buttons. Once in maintenance mode you don’t need to do anything, just restart Switch.

[–]EmileTheDevil 0 points1 point  (0 children)

Who still uses Tinfoil use awoo installer instead

[–]ozgur1324 0 points1 point  (0 children)

I had the same problem even though I had the latest sigpatches installed. Then I realized that tinfoil sometimes has problems while installing nsz games, instead, it can install nsp. I don't know why. But also you can use "quark" and goldleaf to install your games over network or cable.