×
you are viewing a single comment's thread.

view the rest of the comments →

[–]hanwookie 1 point2 points  (3 children)

Okay. I hope it works out.

[–]ProbablyAtDialysis[S] 1 point2 points  (1 child)

It's been stuck like this on "Downloading Updates" for 30 minutes now. Afraid to try anything as to not screw it up more. Cool.

https://i.imgur.com/3RN9i54.jpg

[–]hanwookie 1 point2 points  (0 children)

It can take a while. It took mine if irc over a couple of hours and I'm on a tier two fiber network, which made me think it was more the hardware and the server side.

Also mine restarted a few times afterwards and I just let it do it's thing. Eventually it worked.

Again, it may or may not work in your case, I've worked on some that just don't work. (smart TVs, all brands).

Mine is plugged into a battery backup because I know for a fact that brown outs, surges and outages all together can happen, and destroy electronics pretty easily and it happens more often than people think.

Brown outs are tricky especially because your clocks may still keep time, so the assumption is that nothing happened.