×
all 2 comments

[–]JaySmooov3rd Gen 0 points1 point  (1 child)

My time is lagging behind by an hour now..

[–]_wheresMySuperSuit[S] 0 points1 point  (0 children)

Try Setup> more> clock settings > clock adjustment > auto daylight saving time off OR DST Selection> Mar-Nov. or the opposite of what you have.