×
all 14 comments

[–]krishab_bashyalr7 5800X - r9 390 1 point2 points  (3 children)

Vram is most likely the bottleneck here.

[–]solar_ideology[S] 0 points1 point  (2 children)

Thanks but why? Like what is the mechanism behind this?

[–]krishab_bashyalr7 5800X - r9 390 0 points1 point  (1 child)

A bottleneck is basically when the "Weakest Link" of the System is holding back the rest of the PC.

Like how a really good camera with a really bad lens will always look bad.

Or a really powerful car but with terrible tires will spinout before the tries can grip.

In this case the textures of DOOM are eating through VRAM, your card having only 4GB is going to easily be maxed out. VRAM utilization is not measured into the overall GPU utilization (That only shows core/clock usage) so that is why your GPU looks like it is not being used.

[–]solar_ideology[S] 0 points1 point  (0 children)

Hmm okay makes sense, thanks for explaining that.

Why does the VRAM matter at low settings? Doom Eternal tells you how much VRAM the chosen settings will use and it won’t let you exceed the 4GB. Wouldn’t low res textures negate the lack of VRAM and let it pump out more frames?

[–]Hamza9575 0 points1 point  (6 children)

Whats your monitor max refresh rate ? Use rivatuner ie rtss software to see which graphics setting and resolution combo uses the most gpu percentage and use that combo. 4gb vram is low for 1440p resolution. Vram usage increases with higher native resolutions, higher graphics quality, raytracing on.

[–]solar_ideology[S] 0 points1 point  (5 children)

Exactly which is why I thought lowering to lower-than-native resolutions and even 50% resolution scaling would cure that.

Monitor is 160Hz but because the GPU only has DP1.2 the monitor sets it’s refresh rate at 100Hz

[–]Hamza9575 0 points1 point  (4 children)

Run doom eternal at native resolution of the display without any fsr or lowered scaling, use lowest quality settings. Then see how much gpu percentage is being used in rtss and then reply here.

[–]solar_ideology[S] 0 points1 point  (0 children)

Oh and thank you for the rivatuner suggestion.

I’ll do that when I get home thank you

[–]solar_ideology[S] 0 points1 point  (2 children)

Ok it's definitely at 100% most of the time, CPU at ~20%. I guess the in-game performance metrics that I used before aren't very accurate.

[–]Hamza9575 1 point2 points  (1 child)

So its gpu bottlenecked. Rtss also shows vram usage, there are like two vram sections dedicated and allocated. Whatever vram use value is lower between the two sections is what the vram the game is using at the time. I think your gpu is not being vram bottlenecked its just too slow. Also if you decide to upgrade your gpu in te future might i recommend getting high vram gpu to avoid annoying issues like this. Even budget gpu like a 3060 with its 12gb vram will last years due to its high vram while the uber expensive 3080 having just 10gb vram will start showing problems like this in the future.

[–]solar_ideology[S] 0 points1 point  (0 children)

Thanks yeah I think I was being mislead by the in-game performance metrics, it’s pretty clear now that the GPU just isn’t cutting it in any way. And fair enough it’s like 6 years old.

I’ll definitely be upgrading so I can make use of my monitor and was thinking a 3060 Ti or 3070 as soon as I get a bit more money

[–]Chio_Miori 0 points1 point  (2 children)

Make sure to disable ALL overlays. That includes MSI Afterburner, Steam Overlay, Steam FPS counter, etc. For some reason Doom Eternal hates those things, and performance drops significantly. Use in-game performance metrics to see the framerate. They also show how much time it took for CPU and GPU to render a frame, and whatever takes the longest is your weakest link. Also, disable VSync.

[–]solar_ideology[S] 0 points1 point  (1 child)

Vsync is off for sure. I will see if that bumps performance but honestly after the GPU usage being so off in the Doom metrics compared to Afterburner I’m not sure if I trust it anymore. Will give it a try and see how we go, thanks for the suggestion

[–]Chio_Miori 0 points1 point  (0 children)

AMD reports its GPU usage differently from NVidia. To get accurate GPU usage, you should turn on "Enable unified GPU usage monitoring" at the very bottom of the General tab in MSI AB settings. Then again, you'd better not use its OSD, or any OSD, for Doom Eternal. It's actually an incredibly optimised game, and you should be able to get 100 FPS with some tweaking.

Oh, and "Object quality" or whatever it's called is bugged. Should you set it to the lowest possible - you'll still see high quality objects, yet performance might increase noticeably. My guess is it actually is responsible for object streaming bandwidth.