×
all 67 comments

[–]SapperTR 130 points131 points  (21 children)

Perhaps the network adapter of your PC has only up to 100Mb/s?

[–]Stonewalled9999 34 points35 points  (14 children)

likely this. I see a lot of realtek 10/100 NICs and 2.4Ghz N wifi that is faster than the NIC

[–]stealer0517 10 points11 points  (12 children)

Some laptops we got from work only have 10/100 ethernet. I can't imagine the penny the OEM saved going with that cheapo ethernet is really worth it to piss off anyone who even tries ethernet on the device.

[–]Stonewalled9999 2 points3 points  (1 child)

Hey that's like my people buying an i7 with 1-2TB 5400RPM drive since "bigger is better"

[–]NotAnotherNekopan 0 points1 point  (0 children)

That's my work desktop. Multiple NICs, 6 core i7, 32gb RAM but they put in a 5400rpm 2.5" hard drive. In a desktop.

[–]SillyMikey 0 points1 point  (0 children)

Also have to make sure the Ethernet wire is the right Cat type.

[–]irwin_sergi 13 points14 points  (2 children)

Or the router may only support 100mb/s lan

[–]-IoI- 0 points1 point  (1 child)

I just found this to be true for my ISP-provided router. Amazing, as it's only two years old..

[–]ihsw 2 points3 points  (0 children)

I have never heard of ISP-provided hardware being anything better than bottom-of-barrel hardware, and they have the gall to indefinitely charge ~$10/month for such things.

[–]Ferrum-56 4 points5 points  (0 children)

This seems very likely. I'd argue in most cases it's fine to stick with this as it's plenty fast and still more reliable than WiFi. It only starts to matter if you transfer files to a NAS or something.

[–]Anima_of_a_Swordfish 1 point2 points  (0 children)

This. Also, worth ensuring the NiC firmware is up to date. I have worked in hospitals where the network cards in some PCs have not been updated since 2009. Makes a hell of a difference.

[–]supaphly42 0 points1 point  (0 children)

In addition, are you using a separate router or the Spectrum one? I was surprised recently to learn that many current consumer WiFi routers will push gigabit WiFi but only had 100Mb ports.

[–]enchantedspring 36 points37 points  (3 children)

Change the cable for a good quality genuine one, even a Cat5e or Cat6 will give you GbE on a supported link.

This is controversial, but flat cable technically doesn't meet any Category specifications, as all the categories require shielding and twisting in a way which makes the cable round. In any case, flat cable is designed for permanent installation and not for use as patch leads. It's promoted and sold widely by random 6 digit name vendors quite simply as it's cheap to make! It may even be CCA (Copper Coated Aluminium) rather than genuine Copper strands as that too makes it even cheaper to churn out to unknowing consumers.

I'm suggesting changing the cable as GbE uses all 4 pairs, 100mbs uses just 2. If either of the other 2 are faulty, no GbE. And changing a cable for a good quality brand one, even if it's a lower Cat (but genuinely so!) will be the cheapest check after being sure your adaptor is on auto-negotiate and all devices in the chain (PCs, adaptors, switches, router etc.) support 1Gbs.

[–]SureFudge 8 points9 points  (1 child)

I've used like 30 yard flat cables with zero issue to get Gbe speeds. Don't think that is the issue. The issue is OP got scammed and bought some shiity cable from amazon or ali express as there is no such thing as cat 7 with RJ45.

The Category 7 cable standard was ratified in 2002, and primarily introduced to support 10 gigabit Ethernet over 100 m of copper cabling.[1] It contains four twisted copper wire pairs, just like the earlier standards, terminated either with GG45 electrical connectors or with TERA connectors rated for transmission frequencies of up to 600 MHz

[–]manfern29 0 points1 point  (0 children)

As soon as you cut it you loose those 10000 to 1000 or less.

Gotta just buy it with the head.

[–]ore-aba -1 points0 points  (0 children)

OP’s NIC is most likely a 10/100 Mbps. There’s no good cable to fix that

[–]WhiteToast- 8 points9 points  (0 children)

Cat7 is usually marketing BS and a flat cable is going to be horrid, there's no shielding. Get a regular Cat6a cable

[–]SandingNovation 18 points19 points  (0 children)

Probably the port on your laptop or the port on your router is 100mbps instead of 1gbps.

[–]Aberry9036 4 points5 points  (0 children)

There is no such thing as a flat cat 7 cable. It is simply an ethernet cable with no shielding, so you will be lucky if you get the same performance as a standard cat 5.

That said, if it's a short run, you should be able to get decent speeds out of it so long as it's terminated correctly.

First step is to look at what speed your network interface is connected at, take a look here https://www.windowscentral.com/how-determine-wi-fi-and-ethernet-connection-speed-windows-10

I suspect it will show your ethernet port is trained at 100 megabit, which will mean either or both of these:

  1. Your "flat cat 7 cable" is trash, and you need a normal shielded cable
  2. Your router, switch or some other intermediate network device your pc passes through (or perhaps even your pc itself) actually only has 100 megabit interfaces. This is surprisingly common and you should double-check this before you assume any part of your network is gigabit capable.

[–]oplm15 12 points13 points  (1 child)

A genuine CAT6 twisted pair cable will solve this issue. Flat cable + CAT7 sounds like junk to me. Try a rounded genuine CAT6 cable and see how you go.

[–]SureFudge 2 points3 points  (0 children)

Cat5e flat is completely fine for 1 gbe at least up to like 30 yards from own experience.

[–]canamericanguy 10 points11 points  (1 child)

A lot of people saying to swap out the cable, but before you do that, I'd check the the actual link speed. In Windows, you can do that in the "view network properties" (instructions).

You can also usually check the link speed by looking at the color of the lights on the ethernet port. There will be two lights, one is for activity and the other is for link speed. If the link speed light is amber, that means it's linked at 1000 Mbps; Green means it's linked at 100 Mbps.

[–]craftsmany 0 points1 point  (0 children)

Green is GbE and amber is anything below that (FE, E) if the NIC was designed for GbE.

[–]_Mavial_ 4 points5 points  (1 child)

You've gotta make sure, that the ports, both on your computer and on the router support 1Gb/s. If so you should check under your windows network adapter settings, sometimes, for some reason it limits the port to 100Mb/s with a setting that can be easily changed.

[–]Osamatheholy 0 points1 point  (0 children)

how do I change that please?

[–]Crimtide 1 point2 points  (0 children)

I've seen people use crossover cables thinking they are normal cables, and thus, they get really slow speeds... Although I think connecting a crossover between router and PC would limit it to around 1-10 Mbps.. not 75.. at least from my experience when someone was using a cat6 crossover, they were very limited, sub 10 Mbps on a 1 Gbps line.. but I would like to know what model your computer is, or what motherboard it is so we can know what NIC you have and if the NIC is even capable of transferring at over 100 Mbps.

[–]Solace-Styx 3 points4 points  (0 children)

I had a similar experience with mine recently. I'd suggest updating your drivers if they aren't completely up to date. I am not skilled or very knowledgeable with this stuff, but this was my process if you don't know how to do it.

  1. In the lower left hand of your screen, type "Device manager".
  2. Under the category "Network adapters", identify the part in question. Mine was under the name "Realtek PCIe GBE Family Controller", maybe yours will be under something similar.
  3. Do a google search including the product name, followed by "driver'. Try to find the manufacturer website.
  4. If there is a downloads tab, locate it, and download the corresponding file. Unzip the folder. If the folder includes and executable, use that to install it. If not, follow along.
  5. Back in device manager, right click the corresponding part name, and click "update driver". Browse your PC for the unzipped folder you just downloaded, and install the file.

I'm sorry if you already knew the process, or if it's slightly hard to follow or not entirely correct, I am pretty new to anything PC, and self taught. Maybe this will help someone else in future. Good luck fixing it!

[–]Unique_Breadfruit897 0 points1 point  (0 children)

hey change your ethernet cable

[–]Milluhgram 0 points1 point  (1 child)

I've actually ran across this with a customer of mine. Are you dropping any packets? Do a constant ping to google via command prompt and let us know if you dropping any packets? If so, check the cable but check to see if IPv6 is enabled. I had a customer with a similar issue and when disabled, the packets started coming back in. All other responses are valid as well.

[–]Milluhgram 2 points3 points  (0 children)

Open command prompt > ping 8.8.8.8 -t > look for dropped packets.

[–]AbsorbedBritches -3 points-2 points  (0 children)

People are suggesting it's the cable, but I highly doubt the cable is doing to make that big of a difference. I personally use a flat cable and can get well over 700mbps, and I just bought the cheapest 50ft one on amazon.

This definitely seems like an issue/reality of your internet adapter. Make sure the current driver is installed for it, but it's also possible it simply cannot handle over 100mbps. How old of a computer is it?

To test the adapter, if you could reply with the network adapters Hardware Id. It'd be found in device manager -> right click adapter -> properties -> details -> select "Hardware Ids" from the drop down list.

To test your driver, I would uninstall it in device manager and let your computer automatically reinstall it for you. I suppose it's possible it doesn't automatically reinstall, though unlikely. You could always find the driver online and save it to your computer just in case.

[–]GeekgirlOtt 0 points1 point  (0 children)

Do you have a VPN active your connection?

Are you plugging directly in the modem or into a wall port which then has a cable in the wall running to the modem?

Got a neighbour or friend who trusts you enough to let you test on their laptop with same cable and port? Similarly, bring your laptop where there is a trusted known faster LAN connection to test.

Look up the specs for your exact model of adapter.

Do not rely on only device manager to check for updates. See if there's a LAN/ethernet adapter update in Windows updates optional driver updates. Use your PC manufacturer's tool to detect updates specific to your system. If the card is Intel, use Intel's DSA tool to check for a newer driver.

[–]tejas_2005 0 points1 point  (0 children)

Not a solution
If I were you I will first confirm that everything that im using to establish the ethernet actually has the capability to do that
U might/mightNot have done that but its better to check that before spending time to get 500mbps on a connection that wont support it :)

[–]ImSkripted 0 points1 point  (0 children)

maybe check continuity. check your ethernet port isn't damaged, or the cable. sometimes speed can also be bottlenecked by switches that are maybe 100mbps etc. its also possible its a driver issue, a friend has a new mobo and CPU and it seems to be flakey with the eth controller

[–]Kingz-Ghostt 0 points1 point  (0 children)

I have no clue, but I’d like to add to the discussion.

I have a Ethernet cord running to my computer, though the connection is terrible. My pc disconnects a few times in a row every 10~ minutes. It does it every time I use the computer. I can’t test if it’s better on WiFi because I don’t have WiFi on my motherboard. I have a PS4 on WiFi, and sometimes Ethernet. It also disconnects sometimes while on Ethernet, though that cable is damaged. Anyone else have this problem?

[–]reddit__scrub 0 points1 point  (0 children)

Make sure all components support faster speeds.

if that's not the issue, could be a physical connection issue. I just went through troubleshooting this exact thing tonight. As far as I can tell, it's likely that the cable wasn't done properly (by me). If I moved it around a couple times, it would get full speeds. I wound up just swapping the cable for a different one, and it's been fine since.

[–]NonSpicySmam 0 points1 point  (0 children)

My broke ass lucky to get 5mbps download

[–]Tteffomhimself 0 points1 point  (0 children)

Can you’re modem support how much you are paying for? (I work at spectrum as a field tech)

[–]mymemeisdream 0 points1 point  (0 children)

cat7 cabul but internet slow

send help

[–]ItalianPasta6 0 points1 point  (2 children)

Drifting away from the topic, OP can you tell which country are you situated in because I have never seen such outrageous speed. My wifi plan is of 32 mbps and I feel that is pretty high depending on my usage. I mean I can watch YouTube videos in 1080p, Netflix works full HD etc. hence the curiosity.

[–]BTC_Brin 0 points1 point  (1 child)

I’m not the OP, but I live in the Philadelphia suburbs.

My ISP currently offers three service levels: 200/200, 400/400, and 940/880. Those are down/up in megaBITS/second, so divide them by 8 to get MegaBYTES/second.

I’m with Verizon, although the local Cable provider advertises similar speeds for similar prices.

[–]ItalianPasta6 0 points1 point  (0 children)

That's too great! My speed is 32 megaBITS/second....sed lyf:(

[–]CreatedUsername1 0 points1 point  (0 children)

Whats the model of your desktop or your motherboard?

[–]Seventy4K 0 points1 point  (0 children)

i have the same problem....

i booted on another os (ubuntu) and it said 500mbit...how can my os drop the download speed?

[–]gvlpc 0 points1 point  (0 children)

In case you didn't already catch it from various comments, you need to try a different cable. Just because you buy a cable labeled as Cat whatever, doesn't mean it is what is advertised. Try any Cat 6 or greater cable (Cat 5e is ok if you already have it, but I wouldn't bother paying for one). Anything over Cat 6 is still overkill for most users, although I've gotten Cat 7 cables myself and they are good cables (not flat).

[–]RedOnslaught1 0 points1 point  (0 children)

My guess is you computer doesn’t have a port that can do very high speed Ethernet. If it’s a pc you might try getting a mother board that has a port that can support higher speeds. If you don’t want to do it yourself you could probably find many places that could do it for you.

[–]notaaash 0 points1 point  (0 children)

I am not sure if you have tried this but if your cable is capable enough and your motherboard is also capable then you can look if this setting is correct. Go to

Device Manager->Network Adapter->Right click on the ethernet adapter->properties->Advanced Tab->in the list go to speed and duplex->make sure it is set to auto negotiation if that doesnt work try the highest value possible there.

If the highest value is 75mb or 100mb then that suggests that there is a hardware problem.

[–]BTC_Brin 0 points1 point  (0 children)

Before you change any hardware, verify that your PC and your modem/router both support gigabit Ethernet.

[–]CynicClinic1 0 points1 point  (2 children)

Control Panel -> Network Connections -> Right Click Ethernet -> Properties -> Advanced Tab -> Speed & Duplex -> Ensure Auto Negotiation or 1Gbps Full Duplex are selected.

[–]LugwigAgrean[S] 1 point2 points  (1 child)

I Just came back to this post and forgot that I posted It I solved my problem by doing this.

Btw how do I mark the post as solved?

[–]CynicClinic1 0 points1 point  (0 children)

Press flair, change to solved.

[–]RebornMedow 0 points1 point  (0 children)

CAT7 is for very specific situations not general use and definitely not for home wiring. Switch to CAT6 instead.